Fix rpi touchscreen support on master
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-bsp / bootfiles / rpi-config_git.bbappend
1 DISABLE_OVERSCAN = "1"
2
3 do_deploy_append() {
4     if [ "${ENABLE_CMA}" = "1" ] && [ -n "${CMA_LWM}" ]; then
5         sed -i '/#cma_lwm/ c\cma_lwm=${CMA_LWM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
6     fi
7
8     if [ "${ENABLE_CMA}" = "1" ] && [ -n "${CMA_HWM}" ]; then
9         sed -i '/#cma_hwm/ c\cma_hwm=${CMA_HWM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
10     fi
11
12     echo "avoid_warnings=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
13     echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
14     echo "dtoverlay=vc4-kms-v3d,cma-256" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
15     echo "dtoverlay=rpi-7inch"  >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
16     echo "dtoverlay=rpi-backlight"  >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
17     echo "dtoverlay=rpi-ft5406" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
18     echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
19 }
20
21 do_deploy_append_sota() {
22     echo "device_tree_address=0x0c800000" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
23 }
24
25 ENABLE_UART_raspberrypi3 = "1"