Convert to new override syntax
[AGL/meta-agl.git] / meta-agl-bsp / meta-qcom / recipes-bsp / q6v5-pil / q6v5-pil.bb
1 inherit systemd
2
3 SUMMARY = "Systemd unit file for the delay loading Hexagon PIL kernel module"
4 SECTION = "misc"
5 LICENSE = "MIT"
6 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8 SRC_URI += "file://qcom-q6v5-pil.service"
9
10 do_install() {
11     install -d ${D}${systemd_unitdir}/system/
12     install -m 0644 ${WORKDIR}/qcom-q6v5-pil.service ${D}${systemd_unitdir}/system
13
14     # Blacklist qcom_q6v5_pil to prevent modules autoload
15     # qcom-q6v5-pil.service will do the work after rmtfs done.
16     install -d ${D}/${sysconfdir}/modprobe.d
17     echo "blacklist qcom_q6v5_pil" > ${D}/${sysconfdir}/modprobe.d/qcom_q6v5_pil.conf
18 }
19
20 SYSTEMD_SERVICE:${PN} = "qcom-q6v5-pil.service"