36a983198d6f921f779a73d7705f7075a3f52512
[AGL/meta-agl.git] / meta-agl-bsp / meta-qcom / recipes-bsp / 96boards-tools / 96boards-tools_0.7.bb
1 SUMMARY = "Useful bits an pieces to make 96Boards more standard across the board"
2 HOMEPAGE = "https://github.com/96boards/96boards-tools"
3 SECTION = "devel"
4
5 LICENSE = "GPLv2+"
6 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
7
8 SRCREV = "193f355823d9dc38f370759153ac950a2833b0e2"
9 SRC_URI = "git://github.com/96boards/96boards-tools;branch=master;protocol=https"
10
11 S = "${WORKDIR}/git"
12
13 inherit systemd allarch
14
15 do_install () {
16     install -d ${D}${sysconfdir}/udev/rules.d
17     install -m 0755 ${S}/*.rules ${D}${sysconfdir}/udev/rules.d/
18
19     install -d ${D}${systemd_unitdir}/system
20     install -m 0644 ${S}/resize-helper.service ${D}${systemd_unitdir}/system
21
22     install -d ${D}${sbindir}
23     install -m 0755 ${S}/resize-helper ${D}${sbindir}
24 }
25
26 SYSTEMD_SERVICE_${PN} = "resize-helper.service"
27 RDEPENDS_${PN} += "e2fsprogs-resize2fs gptfdisk parted util-linux udev"