446770f8eb02886b2d51f8e658a8d54e8af3c39c
[AGL/meta-agl.git] / meta-agl-bsp / meta-qcom / recipes-bsp / 96boards-tools / 96boards-tools_0.12.bb
1 SUMMARY = "Useful bits an pieces to make 96Boards more standard across the board"
2 HOMEPAGE = "https://github.com/96boards/96boards-tools"
3 SECTION = "devel"
4
5 LICENSE = "GPLv2+"
6 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
7
8 SRCREV = "ed0f0dbec02c1869a0c4fa0140b4aa5338c9d010"
9 SRC_URI = "git://github.com/96boards/96boards-tools;branch=master;protocol=https"
10
11 S = "${WORKDIR}/git"
12
13 inherit systemd allarch update-rc.d
14
15 do_install () {
16     install -d ${D}${sysconfdir}/udev/rules.d
17     install -m 0755 ${S}/*.rules ${D}${sysconfdir}/udev/rules.d/
18     install -d ${D}${sysconfdir}/init.d
19     install -m 0755 ${S}/resize-disk ${D}${sysconfdir}/init.d/
20
21     install -d ${D}${systemd_unitdir}/system
22     install -m 0644 ${S}/resize-helper.service ${D}${systemd_unitdir}/system
23
24     install -d ${D}${sbindir}
25     install -m 0755 ${S}/resize-helper ${D}${sbindir}
26 }
27
28 INITSCRIPT_NAME = "resize-disk"
29 INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
30
31 SYSTEMD_SERVICE_${PN} = "resize-helper.service"
32 RDEPENDS_${PN} += "e2fsprogs-resize2fs gptfdisk parted util-linux udev"