Convert to new override syntax
[AGL/meta-agl.git] / meta-agl-bsp / meta-iot-cloud / recipes-aws / aws-iot-device-sdk-embedded-c / aws-iot-device-sdk-embedded-c.bb
1 DESCRIPTION = "AWS IoT device SDK for embedded C"
2 AUTHOR = "AWS"
3 HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-embedded-C"
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=acc7a1bf87c055789657b148939e4b40"
6
7 SRC_URI = "\
8     git://github.com/aws/aws-iot-device-sdk-embedded-C.git;protocol=https;branch=master \
9     file://Makefile.aws \
10     file://aws_iot_config.h \
11     file://awsiotsdk.pc \
12 "
13 SRCREV = "d039f075e1cc2a2a7fc20edc6868f328d8d36b2f"
14
15 S = "${WORKDIR}/git"
16 B = "${WORKDIR}/build"
17
18 DEPENDS = "mbedtls"
19 RDEPENDS:${PN} += "mbedtls"
20
21 do_configure:prepend() {
22         cp ${WORKDIR}/Makefile.aws ${S}/src
23         cp ${WORKDIR}/aws_iot_config.h ${S}/include
24         cp ${WORKDIR}/awsiotsdk.pc ${S}
25 }
26
27 do_compile() {
28         cd ${S}/src
29         oe_runmake -f ./Makefile.aws DESTDIR=${D} all
30 }
31
32 do_install() {
33         cd ${S}/src
34         oe_runmake -f ./Makefile.aws DESTDIR=${D} install
35 }
36
37 BBCLASSEXTEND = "native nativesdk"
38
39 ALLOW_EMPTY:${PN} = "1"
40