370b78aae1461419706a9c6a045804b269e818e0
[AGL/meta-agl.git] / meta-agl-bsp / meta-intel / recipes-kernel / lttng / lttng-modules_2.10.5.bb
1 SECTION = "devel"
2 SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3 DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4 LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3 \
6                     file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7                     file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad \
8                     "
9
10 inherit module
11
12 COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm).*-linux'
13
14 SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
15            file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
16            file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
17 "
18
19 SRC_URI[md5sum] = "4aaabaafd15d9455c83972e26ccfbca7"
20 SRC_URI[sha256sum] = "b8dbbbee45a673c381f51b99c555e36655c3c2c7a5477aab927591cc7f003a1f"
21
22 export INSTALL_MOD_DIR="kernel/lttng-modules"
23
24 EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
25
26 do_install_append() {
27         # Delete empty directories to avoid QA failures if no modules were built
28         find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
29 }
30
31 python do_package_prepend() {
32     if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
33         bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
34 }
35