Hotfix for db410 on rocko
[AGL/meta-agl.git] / meta-agl-bsp / meta-intel / recipes-kernel / linux / linux-intel_4.9%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 require recipes-kernel/linux/linux-agl-4.9.inc
4
5 # adding most supported USB Bluetooth, Wifi, and Ethernet devices
6 SRC_URI_append = " file://usb-devices.cfg"
7 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
8
9 # adding support for other graphic cards to work on more PC HW
10 SRC_URI_append = " file://extra-graphic-devices.cfg"
11 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
12
13 # adding internal network in kernel for network boot
14 SRC_URI_append = " file://net-devices.cfg"
15 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/net-devices.cfg"
16
17 # Ensure we have a startup.nsh file
18 SRC_URI_append = " file://startup.nsh"
19
20 do_deploy_append() {
21         install -m 0755 ${WORKDIR}/startup.nsh ${DEPLOYDIR}/
22 }