meta-agl-profile-telematics: recipes-core: systemd: change canbus systemd match regex
[AGL/meta-agl.git] / meta-agl-bsp / meta-intel / recipes-kernel / linux / linux-intel_4.14%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 # adding most supported USB Bluetooth, Wifi, and Ethernet devices
4 SRC_URI_append = " file://usb-devices.cfg"
5 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
6
7 # adding support for other graphic cards to work on more PC HW
8 SRC_URI_append = " file://extra-graphic-devices.cfg"
9 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
10
11 # adding internal network in kernel for network boot
12 SRC_URI_append = " file://net-devices.cfg"
13 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/net-devices.cfg"
14
15 # Ensure we have a startup.nsh file
16 SRC_URI_append = " file://startup.nsh"
17
18 # SPEC-1553 fix for pn333_usb devices not being functional
19 SRC_URI_append = " file://0001-NFC-pn533-don-t-send-USB-data-off-of-the-stack.patch"
20
21 do_deploy_append() {
22         install -m 0755 ${WORKDIR}/startup.nsh ${DEPLOYDIR}/
23 }