Refactor kernel configuration fragment handling
[AGL/meta-agl.git] / meta-agl-bsp / meta-freescale-layer / recipes-kernel / linux / linux-fslc-imx_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:${THISDIR}/files:"
2
3 require recipes-kernel/linux/linux-yocto-agl.inc
4
5 # These patches and the configuration fragment below will need to be
6 # revisited if/when using IMX_DEFAULT_BSP = "mainline" with i.MX8
7 # becomes more feasible with upstream meta-freescale.
8 SRC_URI_append_etnaviv = " \
9     file://0001-enable-mhdp-with-etnaviv.patch \
10     file://0002-dts-enable-etnaviv.patch \
11 "
12
13 # Make sure these are enabled so that AGL systemd configuration works
14 AGL_KCONFIG_FRAGMENTS += " \
15     tmpfs.cfg \
16     namespace.cfg \
17     cgroup.cfg \
18 "
19
20 # Support for CFG80211 subsystem
21 AGL_KCONFIG_FRAGMENTS += "cfg80211.cfg"
22
23 # Turn off a couple of things enabled by default by Freescale
24 # (lock debugging and userspace firmware loader fallback)
25 AGL_KCONFIG_FRAGMENTS += "fixups.cfg"
26
27 # Support for i.MX8MQ EVKB (e.g. Broadcom wifi)
28 AGL_KCONFIG_FRAGMENTS_append_imx8mqevk = " imx8mq-evkb.cfg"
29
30 # Build in etnaviv if required
31 AGL_KCONFIG_FRAGMENTS_append_etnaviv = " etnaviv.cfg"