SPEC-2376: Add virtio configs for QEMU arm/arm64 kernels
[AGL/meta-agl.git] / meta-agl-bsp / meta-core / recipes-kernel / linux / linux-yocto_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
2
3 # Extra configuration options for the QEMU kernel
4 SRC_URI += "file://hciattach.cfg \
5             file://virtio.cfg \
6             "
7
8 # Enable some things on qemuarm64 so MOST drivers will build and load.
9 SRC_URI_append_qemuarm64 = " file://most_deps.cfg"
10
11 # Build a generic v7 kernel instead of the arm926j one that upstream
12 # qemuarm defaults to.
13 KBUILD_DEFCONFIG_qemuarm = "multi_v7_defconfig"
14 KCONFIG_MODE = "--alldefconfig"