Append kernel recipe to support config fragments and add common kernel config fragments
[AGL/meta-agl.git] / meta-agl-bsp / meta-boundary / recipes-kernel / linux / linux-boundary_4.1.15.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 # Enable support for AR9271
4 SRC_URI_append = " file://ath9k_htc.cfg"
5
6 # Enable support for Bluetooth HCI USB devices
7 SRC_URI_append = " file://btusb.cfg"
8
9 # Enable support for Bluetooth HCI USB devices
10 SRC_URI_append = " file://btusb.cfg"
11
12 # Enable support for HID multitouch
13 SRC_URI_append = " file://hid.cfg"
14
15 # Enable support for RTLSDR
16 SRC_URI_append = " file://rtl_sdr.cfg"
17
18 # Set security default to SMACK
19 SRC_URI_append = " file://smack.cfg"
20 SRC_URI_append = " file://smack-default-lsm.cfg"
21
22 # returns all the elements from the src uri that are .cfg files
23 def find_cfgs(d):
24     sources=src_patches(d, True)
25     sources_list=[]
26     for s in sources:
27         if s.endswith('.cfg'):
28             sources_list.append(s)
29
30     return sources_list
31
32 do_configure_prepend () { 
33     cp -a ${WORKDIR}/defconfig .config
34     merge_config.sh -m .config ${@" ".join(find_cfgs(d))} 
35 }