These config fragments are already include through meta-intel-iot-security. Also...
[AGL/meta-agl.git] / meta-agl-bsp / meta-boundary / recipes-kernel / linux / linux-boundary_4.1.15.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 DEPENDS += "kern-tools-native"
4
5 # Enable support for AR9271
6 SRC_URI_append = " file://ath9k_htc.cfg"
7
8 # Enable support for Bluetooth HCI USB devices
9 SRC_URI_append = " file://btusb.cfg"
10
11 # Enable support for Bluetooth HCI USB devices
12 SRC_URI_append = " file://btusb.cfg"
13
14 # Enable support for HID multitouch
15 SRC_URI_append = " file://hid.cfg"
16
17 # Enable support for RTLSDR
18 SRC_URI_append = " file://rtl_sdr.cfg"
19
20 # returns all the elements from the src uri that are .cfg files
21 def find_cfgs(d):
22     sources=src_patches(d, True)
23     sources_list=[]
24     for s in sources:
25         if s.endswith('.cfg'):
26             sources_list.append(s)
27
28     return sources_list
29
30 do_configure_prepend () {
31     cp -a ${WORKDIR}/defconfig .config
32     merge_config.sh -m .config ${@" ".join(find_cfgs(d))}
33 }