new configuration templates based on fragments
[AGL/meta-agl.git] / meta-agl / recipes-sota / ostree / ostree_git.bb
1 SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
2 LICENSE = "GPLv2+"
3 LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4
5 SRC_URI = "gitsm://git.gnome.org/ostree.git;branch=master"
6 SRCREV="${AUTOREV}"
7
8 S = "${WORKDIR}/git"
9
10 DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4"
11
12 RDEPENDS_${PN} = "python libsystemd util-linux-libuuid util-linux-libblkid util-linux-libmount libcap liblzma"
13
14 inherit autotools-brokensep
15
16 EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
17
18 FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
19
20 BBCLASSEXTEND = "native"
21
22 do_configure() {
23  NOCONFIGURE=true ./autogen.sh
24  oe_runconf
25 }