633a3e2484ac93ebeabc70d209ce4f467b478115
[AGL/meta-agl.git] / meta-agl / recipes-multimedia / pulseaudio / agl-audio-plugin_0.1.bb
1 SUMMARY = "AGL Audio Policy Plugin"
2 DESCRIPTION = "AGL PulseAudio Routing plugin, forked from the Tizen IVI \
3 PulseAudio Routing plugin, also known as module-murphy-ivi. This is a \
4 stripped-down version of the former, not needing Murphy anymore and using \
5 either a JSON configuration file or its own embedded configuration."
6 HOMEPAGE = "http://www.iot.bzh"
7
8 LICENSE = "LGPL-2.1"
9 LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
10
11 DEPENDS = "json-c pulseaudio"
12 RDEPENDS_${PN} = "pulseaudio-server pulseaudio-module-null-sink pulseaudio-module-loopback"
13
14 SRCREV = "952d404e87ca6001e546fe9105bdb6760c468760"
15 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/agl-audio-plugin;protocol=https;branch=${AGL_BRANCH}"
16
17 S = "${WORKDIR}/git"
18
19 inherit cmake pkgconfig
20
21 FULL_OPTIMIZATION = "-O1 -pipe ${DEBUG_FLAGS}"
22
23 PULSE_PV="9.0"
24
25 EXTRA_OECMAKE_append = " -DPULSE_PV:STRING=${PULSE_PV}"
26
27 FILES_${PN} += "${libdir}/pulse-${PULSE_PV}/modules/* ${sysconfdir}/pulse/*"
28 FILES_${PN}-dbg += "${libdir}/pulse-${PULSE_PV}/modules/.debug/*"