Fix Weston crash on touchscreen input
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston_%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://0001-compositor-drm.c-Launch-without-input-devices.patch \
5     file://weston.service \
6     file://weston.ini \
7     file://fix-touchscreen-crash.patch \
8     "
9
10 inherit systemd
11
12 SYSTEMD_PACKAGES = "${PN}"
13 SYSTEMD_SERVICE_${PN} = "weston.service"
14
15 do_install_append() {
16     # Install systemd unit files
17     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
18         install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
19     fi
20
21     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
22     install -d ${D}${WESTON_INI_CONFIG}
23     install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
24 }
25
26 FILES_${PN} += " \
27     ${sysconfdir}/xdg/weston/weston.ini \
28     "