217c4fc0b78ec421e06de51d6024953d397edc73
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston_%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://0001-compositor-drm.c-Launch-without-input-devices.patch \
5     file://weston.service \
6     "
7
8 inherit systemd
9
10 SYSTEMD_PACKAGES = "${PN}"
11 SYSTEMD_SERVICE_${PN} = "weston.service"
12
13 do_install_append() {
14     # Install systemd unit files
15     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
16         install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
17     fi
18 }