Forward port local-arm-futex patch to poky morty HEAD
[AGL/meta-agl.git] / meta-agl / recipes-devtools / python / python-pycrypto_2.6.1.bb
1 DESCRIPTION = "Cryptographic modules for Python."
2 HOMEPAGE = "http://www.pycrypto.org/"
3 LICENSE = "PSFv2"
4 LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
5
6 DEPENDS += " gmp"
7 PYPI_PACKAGE = "pycrypto"
8
9 SRC_URI = "file://cross-compiling.patch"
10
11 SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
12 SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
13
14 inherit pypi autotools-brokensep distutils
15 BBCLASSEXTEND = "native"
16 do_compile[noexec] = "1"
17
18 # We explicitly call distutils_do_install, since we want it to run, but
19 # *don't* want the autotools install to run, since this package doesn't
20 # provide a "make install" target.
21 do_install() {
22        distutils_do_install
23 }