bdc196b6f0a4d9f16ed7cc65a81ea12fa19c9813
[AGL/meta-agl.git] / meta-agl / recipes-core / psplash / psplash_git.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 SRC_URI += "file://psplash-colors.h \
4             file://psplash-start.service \
5             file://psplash-quit.service \
6             file://psplash-anim \
7             "
8
9 SPLASH_IMAGES="file://psplash-poky-img.h;outsuffix=default"
10
11 inherit systemd
12
13 SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
14 SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
15
16 do_configure_append () {
17         cd ${S}
18         cp ../psplash-colors.h ./
19 }
20
21 do_install_append () {
22     if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
23         install -d ${D}${systemd_unitdir}/system
24         install -m 644 ${WORKDIR}/*.service ${D}/${systemd_unitdir}/system
25     fi
26     install -m 755 ${WORKDIR}/psplash-anim ${D}/${bindir}
27 }