rygel: disable user systemd service
[AGL/meta-agl.git] / meta-agl / recipes-connectivity / rygel / rygel_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 # Disable everything but the media-export plugin, add the lms plugin
4 PACKAGECONFIG = "media-export lms"
5 PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin,sqlite3"
6
7 # LightMediaScanner plugin patches
8 SRC_URI += "file://0001-Add-LightMediaScanner-plugin.patch \
9             file://0002-lms-add-C-source-files.patch \
10             file://0001-Fix-missing-link-to-unistring-for-lms-plugin.patch \
11             file://rygel.service \
12             "
13
14 inherit systemd
15
16 do_install_append() {
17        # Install rygel systemd service
18        if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
19               install -m 644 -p -D ${WORKDIR}/rygel.service ${D}${systemd_user_unitdir}/rygel.service
20
21               # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
22               # because it does not support systemd's user mode.
23               # However, systemctl --global should be checked
24               #mkdir -p ${D}/etc/systemd/user/default.target.wants/
25               #ln -sf ${systemd_user_unitdir}/rygel.service ${D}/etc/systemd/user/dbus-org.gnome.Rygel1.service
26               #ln -sf ${systemd_user_unitdir}/rygel.service ${D}/etc/systemd/user/default.target.wants/rygel.service
27        fi
28 }
29
30 FILES_${PN} += " \
31     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/rygel.service', '', d)} \
32     "