Remove pyro 2.3.4 conflicts for Ubuntu 18.04 build
[AGL/meta-agl.git] / meta-agl / recipes-connectivity / rygel / rygel_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 LICENSE = "LGPL-2.1"
4
5 # Disable everything but the media-export plugin, add the lms plugin
6 PACKAGECONFIG = "media-export lms"
7 PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin,sqlite3"
8
9 # LightMediaScanner plugin patches
10 SRC_URI += "file://0001-Add-LightMediaScanner-plugin.patch \
11             file://0002-lms-add-C-source-files.patch \
12             file://0001-Fix-missing-link-to-unistring-for-lms-plugin.patch \
13             file://rygel.service \
14             "
15
16 inherit systemd
17
18 do_install_append() {
19        # Install rygel systemd service
20        if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
21               install -m 644 -p -D ${WORKDIR}/rygel.service ${D}${systemd_user_unitdir}/rygel.service
22
23               # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
24               # because it does not support systemd's user mode.
25               # However, systemctl --global should be checked
26               #mkdir -p ${D}/etc/systemd/user/default.target.wants/
27               #ln -sf ${systemd_user_unitdir}/rygel.service ${D}/etc/systemd/user/dbus-org.gnome.Rygel1.service
28               #ln -sf ${systemd_user_unitdir}/rygel.service ${D}/etc/systemd/user/default.target.wants/rygel.service
29        fi
30 }
31
32 FILES_${PN} += " \
33     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/rygel.service', '', d)} \
34     "