Merge pull request #2 from ronan22/master
[apps/agl-service-unicens.git] / conf.d / packaging / unicens-agent.spec
1 ###########################################################################
2 # Copyright 2015, 2016, 2017 IoT.bzh
3 #
4 # author: Fulup Ar Foll <fulup@iot.bzh>
5 #
6 # Licensed under the Apache License, Version 2.0 (the "License");
7 # you may not use this file except in compliance with the License.
8 # You may obtain a copy of the License at
9 #
10 #     http://www.apache.org/licenses/LICENSE-2.0
11 #
12 # Unless required by applicable law or agreed to in writing, software
13 # distributed under the License is distributed on an "AS IS" BASIS,
14 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
15 # See the License for the specific language governing permissions and
16 # limitations under the License.
17 ###########################################################################
18
19
20 Name:    unicens-agent
21 Version: 0.1
22 Release: 1
23 License: Apache-V2
24 Summary: Expose MicroChip UnicensV2 through AGL AppFw
25 Url:     https://github.com/iotbzh/unicens-agent
26 Source0: %{name}_%{version}.orig.tar.gz
27
28 Prefix: /opt/unicens-agent
29 BuildRequires: cmake
30 BuildRequires: gcc gcc-c++
31 BuildRequires: , pkgconfig(libsystemd), pkgconfig(libmicrohttpd), pkgconfig(afb-daemon), pkgconfig(json-c), pkgconfig(mxml)
32
33 BuildRoot:%{_tmppath}/%{name}-%{version}-build
34
35 %description 
36 Expose MicroChip UnicensV2 through AGL AppFw
37
38 %prep
39 %setup -q
40
41 %build
42 %cmake -DBINDINGS_INSTALL_PREFIX:PATH=%{_libdir}
43 %__make %{?_smp_mflags}
44
45 %install
46 [ -d build ] && cd build
47 %make_install
48
49 %files
50 %defattr(-,root,root)
51 %dir %{_prefix}/*
52 %{_prefix}/*/*